1. Guest,
    We need good tech writers that are willing to help out here at ZL-OA. If you like taking photos of jobs as you perform the steps on your repairs, have historical ads/documents from old magazines, or any else you think belongs in the Technical Library than you might be able to help. Send a private message to Furchin, Mudrunner88, Chris, Jarney, Wuputt, or Markus56 and we can lead you in the right direction to get started.
    Dismiss Notice

Fuse box repair service

kawboy Sep 12, 2011

  1. Blue-Grass-Tornado

    Blue-Grass-Tornado _________________________ BANNED

    Oh, sorry. I thought this rebuild thread for fusebox's were for the 1000's only? Do the 900's have the same issues? I've literally got half a dozen 900 fuse boxes laying around!
     
  2. Scoobys_piece

    Scoobys_piece Well-Known Member

    2,026
    0
    71
    Blue~ C #14
     
  3. kawboy

    kawboy Supporting Member Technical Author

    RJ - got your core today, check's in the mail . . . and thanks for the "bonus" :D
     
  4. bsmith

    bsmith Active Member

    102
    1
    28
    Kawboy, thanks bud. Just got a chance to drop mine in tonight, got rid of some very slight hesitations in the idle and hopefully I'm all set with that intermittent cut-out I was having at high-speeds-- hope that never happens again! By the way, the old junction box had been drilled into the back (small hole)... had it been modified/repaired before-- thoughts? I know there are 'new' ones for a concours, but really appreciate it.
     
  5. kawboy

    kawboy Supporting Member Technical Author

    No problem.

    Just 1 small hole? There are 5 rivets that are drilled out to open it.

    I'll take that old one off your hands . . . pm me if interested.
     
  6. naughtyG

    naughtyG Member

    27
    0
    11
    Heya,

    just wondered - are you still offering exchange/repair on these junction boxes? I think mine may just have a bad diode - everything runs great but the side stand safety feature isn't working.
    If you're still doing this I may be interested in buying one off you, and send you mine. Or, if you could point me in the right direction for the diodes I may have a go at it myself, the reason being I'm in western Australia!

    cheers
    nG
     
  7. kawboy

    kawboy Supporting Member Technical Author

    Yes, still doing them. See my reply to your other post.
     
  8. naughtyG

    naughtyG Member

    27
    0
    11
    I've replied in the other post. Let's keep the discussion going there.
     
  9. nick77

    nick77 Active Member

    28
    0
    36
    PM Sent.
     
  10. kawboy

    kawboy Supporting Member Technical Author

    Added ZL600 A & B and ZL900 to original post. These don't seem to be as problematic as the 1K junction box, but I have had a few requests for these.

    I have a 600B box now, ready to go. Working on acquiring the 600A and 900 boxes.

    If you've purchased a box from me, but not yet returned your old one, please do so. Returns keep this service more affordable for everyone.

    Thanks
     
    Last edited: Aug 4, 2015
  11. madmanncr500

    madmanncr500 Well-Known Member

    5,362
    36
    73
    COME ON GUYS IF YOU OWE KAWBOY A CORE......PAY UP OR WE WILL HUNT YOU DOWN:pistols:....................:pk:
    But seriously its guys like KAWBOY who help us all keep these bikes going, and really doing a great job! Thanks to ALL you guys who offer special repair work on parts NO longer available !!!:notworthy:
     
  12. jkrstls

    jkrstls Member

    64
    0
    16
    Are you still doing the fuse box repair? I just got finished installing aftermarket blinkers and now none of them work including the rear running light.. I think I crossed the wires a bunch of times because I didn't think I needed the directions. The aftermarket lights came with 3 wires, black, red, black/white stripe.
    on Bike / Aftermarket
    Front: grey = black/white
    blue = red
    black/yellow = black
     
  13. kawboy

    kawboy Supporting Member Technical Author

    Yes, but it sounds like you need to get your wiring sorted out.

    Also, if you bought LED signals you will need an electronic flasher relay.
     
  14. kawboy

    kawboy Supporting Member Technical Author

    ZL900
    [​IMG]
     

    Attached Files:

  15. Jarney

    Jarney Strip Warrior Staff Member Administrator Super Moderator Supporting Member

    4,475
    11
    133
    Is that one you took apart and are rebuilding or are you building them from scratch? Cool to see either way. Later.
     
  16. kawboy

    kawboy Supporting Member Technical Author

    It's one I'm working on. Took it apart to get everything cleaned up.

    The service manual has you remove the components (relays, diodes, fuses) to test them.
    I want to test everything from the pins on the back of the box, to make sure it works when installed on the bike.
    So gotta go through the diagram and come up with a test plan.
     
  17. R. J.

    R. J. Senior Member

    7,894
    304
    128
    :hello: The PWB & it's components look really good. Do you dip them in a ultrasonic cleaning system.
     
  18. Jarney

    Jarney Strip Warrior Staff Member Administrator Super Moderator Supporting Member

    4,475
    11
    133
    I see, pretty cool. Later.
     
  19. kawboy

    kawboy Supporting Member Technical Author

    No RJ, I use a product called Surface Prep. I think it may be slightly acidic, it really cleans up the copper. Then rinse with alcohol.
     
  20. kawboy

    kawboy Supporting Member Technical Author

    And it's not a "normal" PCB. All those runs are individual copper bars, crimped onto the board. Low-tech, but heavy-duty.
     

Share This Page